Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 23:30 IST
Scheduled
IP Telecom will be performing network maintenance on the IP Telecom platform on the date and time noted in this notification. During this window, we will be conducting testing of our interconnects with our DDoS protection partner.
Service Impact:
While we do not anticipate any service disruption, this is considered an "at-risk" notification due to the nature of the planned activity.
Action Required/Information:
No action is required from customers. However, should any service issues arise during this maintenance window, please report them immediately by opening a ticket with our support team at support@iptelecom.ie.
We appreciate your understanding as we work to improve the security and reliability of the IP Telecom platform.
Posted Apr 16, 2025 - 21:38 IST
This scheduled maintenance affected: Hosted PBX, SIP Trunking, Voice, and Network and Connectivity.