Microsoft Experiencing Direct Routing Issues
Incident Report for IPTelecom
Resolved
The issue has now been resolved by Microsoft. If you still experiencing issues, please contact your Microsoft representative.
Posted Sep 06, 2023 - 11:58 IST
Investigating
We are monitoring issues reported for inbound to teams calls via direct routing. Calls are dropping or stuck in a ringing state even when trying to answer. Outbound calls are intermittently affected.

This appears to be an issue on Microsoft’s end. Please refer to https://downdetector.co.uk/status/teams/
Posted Sep 06, 2023 - 10:46 IST
This incident affected: Teams.