Microsoft Teams calls failing
Incident Report for IPTelecom
Resolved
Microsoft have resolved the issue over night and we are currently seeing lots of successful calls into and out of Teams.
Posted Dec 01, 2023 - 09:13 GMT
Identified
There are issues with inbound and outbound calls for some customers using Teams as their device endpoint. This is related to an ongoing issue that Microsoft have. From their notice:

Scope of impact: This issue may intermittently affect any user attempting to place 1:1 calls, meeting calls or conference calls in Microsoft Teams.

Root cause: An ongoing maintenance action on a portion of infrastructure servicing an API which Microsoft Teams relies on for routing user calls has caused intermittent failures to occur, resulting in users being unable to place calls, or join conferences and meetings.
Posted Nov 30, 2023 - 17:02 GMT
This incident affected: Teams.